Codes
WiiRd forum
November 29, 2021, 03:51:40 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Welcome on the new server

Update 4.3 - do NOT update!
Gecko 1.9.3.1
Should I get a USB Gecko, I wanna hack?
How do I use my USB Gecko
Where can I get WiiRd?
 
   Home   CODE DATABASE GAMEHACKING Help Search Login Register  
Pages: [1]
  Print  
Author Topic: wiirdGUI / usb gecko problem -.-  (Read 4181 times)
gniktar
Newbie
*

Karma: 0
Posts: 15


« on: November 08, 2011, 06:23:41 AM »

so i have been trying to get usb gecko/wiirdgui to work for ghostbusters RGQE70, cause i wanted to play around with infinite health, the codes i have found on the net dont work in the game, so when i try to connect it to usb gecko and do it myself the gecko will say loading game, and then display RGQE70 on both wii and wiirdgui, wiirdgui will then say ghostbusters/RGQE70 on the title bar as if its loaded and ready to go, but the wii has froze on the loading title screen of gecko, and the wii remotes leds have shut off, if i press any buttons, the 4 leds blink a number of times then shuts off again, i have tried to start wiirdgui before goin into gecko, and vice versa, run gecko then open wiird, either way leads to the same result. i tried to tick load VCP in device manager / usb serial converter dialog, but nothing, any ideas?
Logged
dcx2
Computer Engineer
Moderator
Legendary Member
*****

Karma: 165
Posts: 3468


WWW
« Reply #1 on: November 08, 2011, 08:45:57 PM »

Make sure you have the latest USB driver.  http://wiird.l0nk.org/forum/index.php/topic,8950.0.html

You do not want VCP.  The software tools use the D2XX interface.

Make sure you're using the latest Gecko OS.  Make sure you have the debugger enabled.  Make sure you have the hook set to Default or VBI.  If those don't work, try other hooks.  OSSleepThread seems pretty popular.

Personally, I disable SD cheats to prevent any unknown problems from happening.  For instance, if you load a C2 code with SD cheats, and then apply codes with the remote debugger, and the C2 code isn't in the remote debugger's code list, it can cause a crash.

To help with eliminating problems, you should try to boot the game with all the settings I mentioned, but without connecting WiiRDGUI or Gecko.NET.  If it does not work, you have other problems.  You can always attach the remote debugger after the game has loaded.

Oh, right, you should also give us some info on your Wii.  What version of HBC?  What System Menu firmware?  Do you have any custom IOS installed?  What version of Gecko OS are you using?
Logged

gniktar
Newbie
*

Karma: 0
Posts: 15


« Reply #2 on: November 09, 2011, 11:00:08 PM »

ty for the reply dcx2 Smiley

 the homebrew channel i'm currently using is:
                                                                        1.0.8
                                                         IOS 58 v24.31

i also have a few system menu hacks enabled (the white screen that pops up when you hold reset for 5 seconds)
block disc updates:                   enabled
remove diagnostic disc check:   enabled
block online updates:                enabled

the 5sec/reset white screen menu is IOS v6.0 i believe
system menu v54449

in the wii system settings it says my version is 4.1U (i had 4.3 an couldnt install HBC so i reformatted an thats also why i blocked updates)

in HBC i have an app "IOS 58 installer" not sure if this is what you mean by custom IOS installed, but i'm pretty sure i did install that..

not sure what you mean by system firmware, the system version? (v4.1U)

gecko OS version is: Gecko OS 1.9.3.1

Logged
dcx2
Computer Engineer
Moderator
Legendary Member
*****

Karma: 165
Posts: 3468


WWW
« Reply #3 on: November 09, 2011, 11:05:15 PM »

hmm.  Personally, I avoid PriiLoader hacks.  I just avoid the System Menu altogether.  Gecko OS will install any IOS required by a game while leaving the System Menu alone.

Also, you can now use LetterBomb to hack a 4.3 Wii.  Also, if you already have HBC installed, you can upgrade to 4.3 safely.

However, given that you're using PriiLoader, I don't know how wise or unwise it would be to install the official update.

Other than the System Menu it seems like you have all standard stuff installed.  Have you tried running games in Gecko OS with the debugger enabled, but without attaching WiiRDGUI/Gecko.NET?
Logged

gniktar
Newbie
*

Karma: 0
Posts: 15


« Reply #4 on: November 09, 2011, 11:13:42 PM »

i have used gecko OS gct codes for a number of wii games / snes channel games, but so far anything i try to do myself fails. an yeah priiloader sounds familier, thats the white screen isnt it. i read somewhere 4.3 update is only an update to block hbc from being installed (not including the letterbomb) do you think i need 4.3 to use wiird gui and usb gecko?

*edit*: i will google ways to uninstall priiloader before updating if thats necessary
« Last Edit: November 09, 2011, 11:15:17 PM by gniktar » Logged
dcx2
Computer Engineer
Moderator
Legendary Member
*****

Karma: 165
Posts: 3468


WWW
« Reply #5 on: November 09, 2011, 11:18:27 PM »

Every time a new update is released by Nintendo, it blocks the "old" HBC.  And Team Twiizers releases a new HBC in a few days that works around however Nintendo blocked it.

If you have HBC 1.0.8 it's perfectly safe to update, assuming that nothing goes wrong with PriiLoader.

By the way, do you know if you installed BootMii as boot2?  If so then you're 100% safe in doing anything, assuming you backed up your NAND.

---

You do not need 4.3.  Personally I'm running 4.2 (or 4.1, can't remember).

What happens if you start a game, and then after you get into the game, you connect with the remote debugger?
Logged

gniktar
Newbie
*

Karma: 0
Posts: 15


« Reply #6 on: November 09, 2011, 11:27:30 PM »

i uninstalled oriiloader anyway, doesnt seem like i need it.

when i disconnect usb gecko from my wii/pc and start homebrew channel / gecko OS / run the game through gecko OS, and then attach usb gecko and wiird gui, wiird gui just says "starting.." on the title bar, but never loads the game
Logged
dcx2
Computer Engineer
Moderator
Legendary Member
*****

Karma: 165
Posts: 3468


WWW
« Reply #7 on: November 09, 2011, 11:35:58 PM »

The USB Gecko should be in GC memory card slot B all the time, even if you aren't using it.  You can also leave the USB Gecko connected to the PC over USB.

So, connect USB Gecko to Wii and PC.  Do NOT load the remote debugger (WiiRDGUI/Gecko.NET) yet.  Device Manager on the PC should have "USB Serial Converter", which is the USB Gecko.  HBC should have a Gecko icon in the corner that lights up.

Start your game with Gecko OS.  Make sure you have the debugger enabled, and make sure you have a hook set, and pause-start is NOT set.

Get into the game.  Get past the main menu and into some level.  Once you are in a level, then start the remote debugger.
Logged

gniktar
Newbie
*

Karma: 0
Posts: 15


« Reply #8 on: November 09, 2011, 11:51:13 PM »

i have usb serial converter, it is under universal serial bus controllers, load VCP is not ticked, usb gecko is in slot B (was in slot A) gecko never lit up before, but now it looks like it is, 2 icons on the lower right are lit up, 1 is prolly the gecko on the left and the one on the right is a circle with 3 curved lines above it, gecko os debugger option was disabled, now its enabled along with the default gecko hook type, sd cheats is disabled, infact everything in the config of gecko os is disabled except hook type and debugger n game language. i get into a level and then open wiird gui, it dumps the file an loads ghostbusters, so hopefully my searches work, the problem must have been that usb gecko was in slot A, ty for the help dcx2 ^.^()

i will now test run a search for health an see if it all works  Smiley
Logged
dcx2
Computer Engineer
Moderator
Legendary Member
*****

Karma: 165
Posts: 3468


WWW
« Reply #9 on: November 09, 2011, 11:55:33 PM »

Glad I could help.

Slot A would explain why you had some problems, but I'm still very surprised that it was able to work at all, even if it broke after the first dump.

For future reference, you should be able to connect the remote debugger to the game while you're still in Gecko OS, and it should auto-launch a disc-based game (but not channels).  The whole "start the game then connect later" was just an exercise in the process of elimination.

EDIT:

Also, you might want to click the "latest test build" in my sig.  Gecko.NET is a newer remote debugger that Link and I worked on.  It has some additional features that aren't in WiiRDGUI.
Logged

gniktar
Newbie
*

Karma: 0
Posts: 15


« Reply #10 on: November 10, 2011, 12:11:24 AM »

nice, will do, ty again  Smiley
Logged
gniktar
Newbie
*

Karma: 0
Posts: 15


« Reply #11 on: November 10, 2011, 01:41:20 AM »

Also, you might want to click the "latest test build" in my sig.  Gecko.NET is a newer remote debugger that Link and I worked on.  It has some additional features that aren't in WiiRDGUI.


very nice dcx2 and link, someday i wanna be as smart as you two.. im trying to learn c++ programming via a "learn c++ through game programming" book, but its gonna take aloong time to come anywhere near to the work you have done in gecko dnet Smiley
love the screenshot feature
Logged
CodeCracker
Newbie
*

Karma: 0
Posts: 2


« Reply #12 on: December 10, 2011, 12:19:18 PM »

Hopefully someone else has had the same problem I am having. The problem I am having is that when trying to connect Wiird to my Gecko device nothing happens or if something does finnally happen it crashes. But, the thing is, is that I do not have this problem with Windows Vista, only in Windows 7. I have the latest drivers for the Gecko device, newest version of WiiRD, Gecko card in Slot B and I have done everything others have said to do in this post.

Sometimes I do get a connection and everything works correctly, but that is usually after I have unplug the USB cord from the computer and waited for a window to come up and say cannot connect to Gecko device, would you like to try again or something like that. When I reinsert the USB cord and hit try again it does connect and I am able to play the game, but that only works about 1% of the time and other times it crashes. I hope some one out there will be able to help me with this or the person who created the program can find out what or where the problem is and fix it.

One more thing, I have used Wiird with other computers that have Windows 7 installed and they too have the same problem.
Logged
GMO
Mahal Din Kita Jen!
Hacker
Sr. Member
*****

Karma: 56
Posts: 461


I Make Things Interesting


WWW
« Reply #13 on: December 14, 2011, 04:16:13 PM »

I'll see if I can write up a trouble shooting guide for people

But here are some drivers for you

Original USB Gecko Drivers (Disk)
http://mediafire.com/?p2ev10lb0d66vpb

Here are the Updated Drivers from earlier this year
http://mediafire.com/?f2x6gxetris2zdu
Logged

http://gamemasterzer0.blogspot.com
For Codes, Guides, & Support Codemasters-Project
USB Gecko Facebook Page - My Wii's 4.1 U | 4.0 E
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!